WorldClassRoom FAQsFAQ News RSS

For Those Using Internet Explorer

Internet Explorer version 9 (IE9) is no longer a supported browser for use with Webster's WorldClassRoom.  (Note: all IE versions below 9 are currently not supported.)

If you are an IE9 user (or using an older version of IE), you will see a warning message when you log in stating your browser is unsupported.  Over time, you may see an increase in technical issues and glitches, or even not be able to log in, which may impede your ability to fully participate in your online courses.

If you are an IE9 user, we recommend that you take the following actions:

You cannot comment on this entry